Defrag 20 Bugs

Professional / Workstation / Server Edition
Antworten
tt_1111
Beiträge: 8
Registriert: So 20. Dez 2015, 18:58

Defrag 20 Bugs

Beitrag von tt_1111 » Di 15. Nov 2016, 14:29

Die 20er Version 20.0.449 enthält mehrere Bugs. Um drei zu reproduzierbare zu nennen:

1. Bei hoher sonstiger CPU-Belastung verabschiedet sich das Hauptfenster ziemlich sofort.
2. Wenn man ein anderes Farbschema (zur Anzeige des Laufwerkstatus) festgelegt hat, wird das nach jedem Start erst aktiv, wenn man mindestens eine der Farben zur Änderung des Schemas anklickt. Vorher erscheint stets das blasse Standardschema.
3. In der Spalte 'Aktuelle Datei/Verzeichnis' wird grundsätzlich nichts angezeigt, auch wenn nachweisbar gerade eine Defragmentierung läuft. Edit: Geht bei v457.
4. Die Spaltenbreiten in dem Diskstat-Tab sind nach jedem Neustart auf den (viel zu kleinen) Standard zurückgestellt.

Alles Sachen, die bei Version 19.x nicht vorhanden waren. Solche Bugs sollten eigentlich beim Übergang von Alpha- zu Beta-Versionen entdeckt und spätestens mit dem ersten Release Candidate ausgemerzt sein. Normale Kunden damit zu traktieren und sie zu erweiterten Beta-Testern zu ernennen, gehörte in früheren Jahren zur Praxis von Microsoft. Schade, dass OO sich solche Praktiken aneignet.

Ich will gar nicht erst über das 'Farbschema' des Programms (eigentlich besser: Farblosschema) debattieren, über Geschmäcker lässt sich bekanntlich nicht streiten. Da sonstige Konsolenanwendungen den Windows-Farbschemata folgen und O&O Defrag sich ohne mit der Wimper zu zucken in die (Konsolenanwendung) 'Computerverwaltung' einklinkt (wo es übrigens nicht ständig abstürzt), muss ich allerdings schlussfolgern, dass die extrem schlichte und anscheinend nicht anpassbare Optik so gewollt ist.

tt_1111
Beiträge: 8
Registriert: So 20. Dez 2015, 18:58

Re: Defrag 20 Bugs

Beitrag von tt_1111 » Do 17. Nov 2016, 18:02

Addendum – und noch einer:

Umfangreichere Jobs werden oft als 99% angezeigt und bleiben da dann stundenlang stehen. In Wirklichkeit sind sie vermutlich abgeschlossen, bloß das Statusfenster wird nicht aktualisiert.

Benutzeravatar
Martin (O&O)
Beiträge: 715
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Defrag 20 Bugs

Beitrag von Martin (O&O) » Di 22. Nov 2016, 11:23

Hallo,

vielen Dank für das Feedback. Ich habe Ihre Hinweise an unsere Entwickler weitergeleitet.
Der Punkt 3 ist bereits gefixt und Punkt 4 sollte im nächsten Update gelöst sein.

Die Kollegen schauen sich das Ganz mal an.


Martin (O&O)

tt_1111
Beiträge: 8
Registriert: So 20. Dez 2015, 18:58

Re: Defrag 20 Bugs

Beitrag von tt_1111 » Mi 7. Dez 2016, 14:54

Hallo Martin,

danke für die Rückmeldung.

Gleich noch einen Punkt für die Entwickler:

Wenn man als Bildschirmschoner 'Defrag' einstellt, funktioniert das ganz wunderbar. Offenbar standardmäßig und unveränderbar als 'Space' Defragmentierung. Selbst dann, wenn man Zonen für seine HDDs definiert hat. Diese werden bei der Bildschirmschoner-Defragmentierung gnadenlos zerschossen, alles wird hintereinander geschrieben.

Bei der nächsten Defragmentierung nach Zeitplan wird dann wieder versucht, die Zonen aufzubauen.

Irgendwie kontraproduktiv. Auch der Bildschirmschoner sollte auf die gespeicherten Einstellungen (entweder Zonen oder [exclusive or] Space) zugreifen und sich danach richten.

Benutzeravatar
Martin (O&O)
Beiträge: 715
Registriert: Mo 27. Jun 2011, 13:07
Kontaktdaten:

Re: Defrag 20 Bugs

Beitrag von Martin (O&O) » Mi 7. Dez 2016, 15:46

Hallo,

dieses Problem können wir hier leider nicht nachvollziehen da der Bildschirmschoner sich entsprechend konfigurieren lässt. Hierbei lassen sich auch die Defragmentierungsmethoden definieren:
Screensaver.JPG
Martin (O&O)

Antworten