Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Professional / Workstation / Server Edition
markalex
Beiträge: 5
Registriert: Do 3. Mär 2016, 14:48

Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon markalex » Do 3. Mär 2016, 15:21

Ich habe auf meinem Windows 7 Home Premium/SP 1 Diskimage 9.10.1020 Prof. installiert. Nach dem Neustart des Systems befand sich (ungefragt) eine O&O Diskimage Symbol auf der Taskleiste. Seit diesem Neustart klappt das reibungslose An- und Abmelden von USB-Laufwerken nicht mehr, insbesondere das Abmelden.

Wenn ich ein externes LW per USB3 anschließe, kann ich es benutzen, aber wenn ich es abmelden will (über "Hardware sicher entfernen und Medium auswerfen"), funktioniert dies nicht. Das Symbol für angeschlossene USB-LW bleibt in der Taskleiste und es erscheint nicht die Meldung, dass "Die Hardware jetzt" entfernt werden könne. Selbst ein Herunterfahren des Systems ging nicht, so dass ich den PC ausschalten musste, um dann neu zu starten. Offenbar blockierten die nicht ordnungsgemäß abgemeldeten Laufwerke das Herunterfahren.

Versuchsweise habe ich mit msconfig im Systemstart O&O DiskImage deaktiviert, was aber nichts veränderte. Erst das Außerkraftsetzen des Dienstes "OO DiskImage" im 'Abgesicherten Modus' erlaubte mir wieder ein korrektes Nutzen der externen USB-Laufwerke.

Das kann es aber wohl doch nicht sein!?

Benutzeravatar
Brigitte (O&O)
Beiträge: 585
Registriert: Mo 27. Jun 2011, 13:06

Re: Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon Brigitte (O&O) » Fr 4. Mär 2016, 14:57

Hallo Markalex,

es handelt sich hier um ein sehr vereinzelt auftretendes Problem, siehe hier:

http://forum.oo-software.de/viewtopic.php?f=27&t=953

Die Ursachen des Problems sind uns leider nicht bekannt, vermutlich ein Zusammenspiel zwischen Hardware und System. In einem solchen Fall wäre der Workaround den Dienst von O&O DiskImage zu beenden bevor das Laufwerk sicher getrennt, bzw. der Rechner heruntergefahren wird.
Brigitte (O&O)

markalex
Beiträge: 5
Registriert: Do 3. Mär 2016, 14:48

Re: Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon markalex » Fr 4. Mär 2016, 20:04

Hallo Brigitte,

vielen Dank für die Antwort. Ich bin mir nicht darüber im Klaren, ob bei mir dasselbe Problem vorliegt. Ich habe noch gar keine Sicherung erstellt, aber seit der Installation von DiskImage 9 ist das Traysymbol unter Systemstart eingetragen und der Dienst OO Diskimage wird ausgeführt. Diesen zu stoppen wird mir aber verwehrt, weshalb ich das System heruntergefahren habe, um den Dienst im Abgesicherten Modus zu stoppen, was dann möglich war.

Solange der Dienst aktiv war, klappte das Anschließen externer Laufwerke nicht mehr korrekt, beim Versuch, sie wieder abzumelden, blieb im Explorer tw. das Laufwerksymbol bestehen, aber ohne Anzeige des LW-Inhalts. Das Taskleistensymbol für angeschlossene LW (kleiner USB-Stick mit grünem Haken) blieb, aber statt eines LW waren nur zwei, drei Punkte zu sehen.

Das Taskleistensymbol von DriveImage ist vermutlich entbehrlich, aber der Dienst 'OO DiskImage' wird ja wohl benötigt für ein ordnungsgemäßes Funktionieren von DiskImage, oder? Reicht es, wenn ich ihn für die Durchführung eines Backups ausführe und hinterher wieder desaktiviere?

Benutzeravatar
Brigitte (O&O)
Beiträge: 585
Registriert: Mo 27. Jun 2011, 13:06

Re: Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon Brigitte (O&O) » Mo 7. Mär 2016, 13:16

Hallo Markalex,

das TrayIcon kann deaktiviert werden, es ist nur zur Information da. Der Dienst wird jedoch benötigt. Wenn Sie die Sicherungen manuell ausführen möchten können Sie den Dienst auch deaktivieren und erst starten bevor Sie O&O DiskImage nutzen möchten.
Brigitte (O&O)

markalex
Beiträge: 5
Registriert: Do 3. Mär 2016, 14:48

Re: Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon markalex » Mo 7. Mär 2016, 20:31

Ja, so wird es wohl gehen. Allerdings: wenn der Dienst erst mal gestartet ist, verweigert er nach dem Backup bzw. überhaupt das Wieder Beenden. Ich muss also einen Neustart des Systems machen, damit die Probleme mit dem Abmelden von USB-Laufwerken aufhören. Ziemlich lästig, erst recht, wenn man regelmäßig Backups machen will + normalerweise den PC abends nur in den Ruhestand versetzt statt Herunterzufahren.

Aber vielleicht hat ja noch jemand eine Idee, woran die Abmeldeprobleme liegen können. Sonst muss ich wohl eher auf DiskImage verzichten....

Benutzeravatar
Brigitte (O&O)
Beiträge: 585
Registriert: Mo 27. Jun 2011, 13:06

Re: Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon Brigitte (O&O) » Di 8. Mär 2016, 12:18

Hallo Markalex,

welche Fehlermeldung erhalten Sie wenn Sie den Dienst beenden?
Brigitte (O&O)

markalex
Beiträge: 5
Registriert: Do 3. Mär 2016, 14:48

Re: Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon markalex » Di 8. Mär 2016, 20:50

Es kommt einfach nur die Meldung, dass "dieser Dienst" nicht beendet werden kann. Ich vermute mal, dass durch das Starten von DiskImage nicht nur der Dienst selbst automatisch gestartet wird (ich habe ihn auf 'Manuell' eingestellt, wodurch er beim Systemstart nicht automatisch ebenfalls startet), sondern damit für den Rest der Sitzung (d.h. bis zum Herunterfahren) blockiert ist - und damit bei mir irgendwie die An- und Abmeldung von USB-Laufwerken stört.

Benutzeravatar
Brigitte (O&O)
Beiträge: 585
Registriert: Mo 27. Jun 2011, 13:06

Re: Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon Brigitte (O&O) » Mi 9. Mär 2016, 15:34

Hallo Markalex,

wenn Sie den Dienst auf "manuell" gesetzt haben zieht O&O DiskImage diesen hoch, wenn Sie das Programm öffnen. Das beenden des Dienstes über die Windows Diensteverwaltung sollte aber dennoch problemlos möglich sein oder läuft gerade eine Sicherung? Um Probleme zu vermeiden setzen Sie den Dienst auf "deaktiviert". Wie ist dann das Ergebnis?
Brigitte (O&O)

markalex
Beiträge: 5
Registriert: Do 3. Mär 2016, 14:48

Re: Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon markalex » Mi 9. Mär 2016, 19:21

Wenn ich den Dienst auf "Deaktiviert" stelle, gibt es keine Probleme, weil ja die Probleme erst bei aktiviertem Dienst auftreten. Dann kann ich aber doch wohl auch keine Sicherung durchführen...

Sobald der Dienst einmal aktiviert ist, nützt es nichts, DiskImage zu beenden, weil der Dienst dann trotzdem weiter aktiv ist. Eine Sicherung habe ich bisher eh noch nicht vorgenommen, da es keinen Sinn macht, Sicherungen mit einem Programm auszuführen, welches das Funktionieren meines gesamte Systems behindert.

Aber ein Deaktivieren funktioniert trotzdem nicht, irgendetwas blockiert dies. Leider teilt Windows nicht mit, WARUM ich den Dienst nicht wieder abschalten kann.

Und solange die Nutzung externer Speichermedien auf diese massive Weise behindert ist (nutze ich eigentlich ständig für Datenbackup bzw. -austausch zwischen verschiedenen Geräten), ist DiskImage für mich nutzlos.

Benutzeravatar
Brigitte (O&O)
Beiträge: 585
Registriert: Mo 27. Jun 2011, 13:06

Re: Nach Installation Diskimage Probleme mit An-/Abmeldung USB-Laufwerke

Beitragvon Brigitte (O&O) » Do 10. Mär 2016, 12:59

Hallo Markalex,

ich verstehe zwar Ihre Unzufriedenheit, aber das Problem das bei Ihnen auftritt ist wirklich sehr sehr selten. Nichtsdestotrotz werden wir Ihr Feedback an unsere Entwicklungsabteilung weiterleiten.
Brigitte (O&O)


Zurück zu „O&O DiskImage“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 5 Gäste